5.3.3 doesn’t seem to work

Has anybody else had a problem with 5.3.3? I just installed this and it’s not responding on any ports. Tried rebooting the server, reinstalling the app, checked the firewall - nothing seemingly wrong. The service was running (it’s a windows server).

I reverted back to 5.3.2 and all is fine.

Same here. Totally pooch screwed our remote server. When we revert back to 5.3.2, some machine are not communicating.

Same here. Reverted to 5.3.2.

Bear in mind support does not monitor this board. Please submit a ticket at https://simple-help.com/support-tickets to let them know.

Seems ok here
what build are you using, i am using 5-3-20211122-105859

No issues after updating to 5.3.3 today.

I have a Linux server and have had no issues since install yesterday early morning.

I had the SAME issue as others today. I upgraded from 5.3.2 to 5.3.3, and the server is no longer responding. It doesn’t even show it is listening on port 80…
Went back to 5.3.2 and it is working again. I opened a trouble ticket with SH…

Chris from Simplehelp told me that it’s a problem that affects some setups, especially when using a virtual machine. They’re working on a fix.


Where can you find old versions? My 5.3.3 Windows setup is probably worse with rendering issues. I can find it in my backup. Maybe the downloads should have the version number in the file as do most downloads so you don’t overwrite the last version.

What’s the process for going back? Just re-install the old version?

I had the same issue.

Here is the link to find older versions


Was wondering about the process myself.

Yep. Just reinstall and good to go. That’s what I did anyway. My build is on a standard win 10 pro, no VM and had the issue. Luckily I tested it on our backup server first before deploying it to our main server, which is on a VM.

1 Like

I received a reply back from Support with two work-arounds. It turns out that on SOME configurations of OS’s, there is a missing file. One of the work-arounds was a beta version of 5.3.4 which worked.

Hi, Paul: Is there any information about that missing file? Thx

Here is what they mentioned. I will tell you that I tried the work-around1, and it did NOT work for me… Paul

Hi Paul,

Apologies. It looks like certain Windows installs don’t have a complete set of required dependencies. We don’t see it at all, even with a clean installation, but other users are seeing it.

To get up and running you should be able to do one of the following:

  1. Copy %PROGRAMFILES%\SimpleHelp\jre\bin\vcruntime140.dll to %PROGRAMFILES%\SimpleHelp


  1. Try out 5.3.4 from here:


Oh, and in step 2, it worked, but it showed a MUCH older build version… In the long run, I just went back to 5.3.2, and I will wait until 5.3.4 is official.

Paul when you install the update do you usually stop the simple-help service or do you upgrade while the service is running? I always stop the service before upgrading, upgraded to 5.3.3 today and no problem, almost all my clients are already updated as well.

There was a problem with 5.3.3. 5.3.4 is out with the dependency fix.

1 Like