5.3 black screen issue /w discreet graphics card

I upgraded my server to 5.3.7 (from 5.2.18) to see if any of my previous issues with the black screen had been resolved, but I ran into the same issue again that I had before on 5.3.x. I did narrow it down to the following configs:

All machines:

  • Windows 10/11
  • Discreet graphics card
  • Headless

Most machines also have integrated graphics Intel/AMD but some Intel F or AMD X CPUs without. I have sampled 15 machines all have the same issue with displaying the black screen.
Interesting enough the screenshot with monitoring turned on is displaying the desktop.

I have reverted back to 4.2.18 were the issue is not there (although Windows 11 is not 100%).

Yes I am also submitting a ticket with this information, in the mean time how do I remotely revert the service on a machine to 5.2 that that already updated to 5.3 without alternative access? Any help would be greatly appreciated.

1 Like

This is a pretty common problem with remote access programs, simplehelp included.

1 way is to use dummy adapters or edid emulators:

The second way, although unreliable and a pain: Plugin a display, log in to the machine, and don’t let the machine reboot or fall asleep. Unplug display.

I have seen some programs get around this by installing a virtual adapter and with a driver, although this can cause other issues with programs that autodetect what graphics adapter to use.

1 Like

I should also note, this issue is not limited to windows or Simplehelp + windows. I have the same issue with a linux steam machine I built and steamlink.

I know it also happens with vnc and connectwise.

If memory serves correctly, with headless machines you can try disabling Graphics acceleration.
I believe it checks for a display. If you turn graphics acceleration off it shouldn’t check for a display and should work.

That may be why it works in 4.2 but not in newer versions ?

If you wanted to disable graphics acceleration and see that works I believe this batch script should work for you.

REM 1 =off 0=on
REG ADD HKCU\Software\Microsoft\Avalon.Graphics /v DisableHWAcceleration /t REG_DWORD /d 1 /f
REM 1 =off 2=on
REG ADD HKLM\System\CurrentControlSet\Control\GraphicsDrivers /v HwSchMode /t REG_DWORD /d 1 /f

Curious to see what you discover. Please post your findings.

Thanks Darrell for your replies, I mistakenly said 4.2.18 where I meant 5.2.18

I tried the batch script (with changes made successfully and reboot) on 5/15 different systems with different configs, unfortunately it did not resolve the problem running 5.3.x.

Reverted the server back to 5.2.18 from 5.3.x and all the all the systems display 100% although some at lower resolution but still workable. Something changed going from 5.2 to 5.3 that stops it from working.

This problem never happened to me with SimpleHelp on many other systems prior to 5.3, it is really something that changed at that time.

I appreciate your suggestion of an HDMI Dummy of which I will get a couple ordered to see if it helps with the issue, while hoping that the change can still be identified.

Very interesting. Keep us posted on what you find out.

If you haven’t already I would recommend raising this to George and the support team and passing on the Tech and RemoteAccess logs for review.

There was pretty significant underlying changes in how SimpleHelp detects screen changes in v5.3 where the OS now notifies the session that a portion of the screen has changed, before SimpleHelp validates those changes before sending them along. This only applies to new Windows OS (I think from Windows 10 onwards).

In some of our testing we did have cases where machines were just showing a grey screen, which sounds similar to what you are reporting, however we have not yet got to the point of rolling out v5.3 across all of our systems so this was isolated to our test environment only.

Yes all with Windows 10/11, this would be easy to replicate on a 5.3.x machine with dedicated GPU and a headless boot/reboot without a monitor connected. I don’t have any on hand yet but assume a dummy could mitigate this.

As mentioned it would still be nice if if could function the way it did before these changes where made as the majority of machines are running the new Windows OS.

Got a reply from Support, looking forward to further improvements. Will report on the dummy’s in the mean time when received.

Headless machines are going to be better served in 5.4 following several capture improvements. While not a particularly convenient workaround, some users have reported disabling the non-integrated card helps.

Quick follow up that HDMI dummy mitigates the issue for now.

1 Like