Adding Let's Encrypt Cert

For the life of me I cannot get an SSL cert to work. I had 80/443 open to let it go automatically and have tried installing it manually too but it won’t take a certificate. I am going to wait until 5.5 comes out before trying again but it has been a bit frustrating. I read the manual page that says all connections are encrypted but people get a bit nervous when the download page says ‘not secure’.

Anyone had any luck?

Odd, I have 2 installs. One with lets encrypt from within Simplehelp and one using a wildcard that I uploaded. No issues with either.

Along with the ports being open, are you running simplehelp on port 443 and 80, or another port?
Does it give you any errors?
Also, check your server log, there may be error information that could help.

If you open a support ticket and send your server log to them, they should be able to pinpoint the issue pretty quickly.

Oh and is this a windows server or Linux? Make sure your lets encrypt root certificates are up to date on the server OS.

Debian 12 on another port originally. I tried using ‘sudo certbot certonly --key-type rsa --manual --preferred-challenges=dns -d domain.com’ and telling SH the folder to look in but it doesn’t like it. Same when I opened 80/443 and tried the automated keygen. I forgot to write it down but I think it isn’t liking privkey.pem. Thought it was because of a ECDSA key on my first try. That or the router is filtering something out.

Third time’s the charm I guess. It won’t look at the local folder where certbot saves the files. Maybe because it adds a 1 to the end of the files like privkey1.key? I redid everything and manually uploaded the cert, priv, and chain files and it took it this time.

Thanks for your time.

Good to know. I never used the grab from folder option. Glad you got it sorted.