Install on chromeBook

did you install the technician controller on a chromebook?

I try with the linux version but after decompression of the tar I’m stuck, I looked on the site and forum no more info …

thank you

Where are you stuck? What issue are you running into?
You should be able to extract the tarball and then run the script to start the server.
Also, this is the official step by step guide…have you checked this page out yet as well?

thanks for the feedback but this manual is for the server installation, I’m looking for the tech console

My apologies, I see I misread.
I have a chromebook and have the tech console installed.
I downloaded the tech console full application from my server and just extracted the tar file and then ran the executable.
So circling back, what issue are you having. Are you trying to run the executable but finding that it just isn’t running? Double check that it has executable permissions… (chmod 755)

Download the tar.
Extract the tar.
Change permissions to execute file:

chmod 775 SimpleHelp Technician-linux64-offline

execute the file:

sh SimpleHelp Technician-linux64-offline

Please keep in mind that right now you can only install on an x86 chromebook. If your chromebook is arm based it will not work yet (coming soon in 5.3).

Thx [Darrell_Swafford]

I hadn’t thought about chmod

it works perfectly on a used A4 100 euro :slight_smile:

Pardon for taking this thread on a slight tangent. Is it possible to install SimpleHelp (client) on a Chromebook? Might it be a simple enough task for a real neophyte to try? Thanks!

re: client install - you might be able to, but you would only have access to the linux container, not the OS that the user uses, and definitely not able to see their screen. For chromebooks we’ll normally use something like chrome remote tool ( ).

Thanks. Will look into it

Haven’t tried the SimpleHelp Access Client, only the tech client. Tech client definitely works. :slight_smile:

1 Like

I’ve been trying to install the technician console on my Chromebook and was able to download and extract the file, but I get this run trying to run it:

~$ sh SimpleHelp-Technician-linux64-offline
SimpleHelp-Technician-linux64-offline: 2: SimpleHelp-Technician-linux64-offline: Q�N���
�p��J����nöH�R: not found
SimpleHelp-Technician-linux64-offline: 4: SimpleHelp-Technician-linux64-offline: Syntax error: “(” unexpected
removed@penguin:~$ SimpleHelp-Technician-linux64-offline: 1: SimpleHelp-Technician-linux64-offline: ��: not found
SimpleHelp-Technician-linux64-offline: 2: SimpleHelp-Technician-linux64-offline: ��i�@@: not found
SimpleHelp-Technician-linux64-offline: 1: SimpleHelp-Technician-linux64-offline: ELF: not found

Any help would be appreciated.

Hi Jason.
What model of Chromebook? is it arm based? or intel/x64?

It’s an Acer Chromebook 311 with an Intel Celeron N4020. I also ran the following command: uname -m and got x86_64 as the result.

after you extracted the TAR, did you chmod the file before executing it?
chmod 775 SimpleHelp-Technician-linux64-offline

It looks like your executing the wrong filename unless you renamed it. When I extracted mine the file name is: “SimpleHelp Technician-linux64-offline” not “SimpleHelp-Technician-linux64-offline”

Thats probably why you got “not found” error.

I did chmod the file. I changed the filename to SimpleHelp-Technician-linux64-offline because it wouldn’t recognize the file with the space between SimpleHelp and Technician.

Am I correct in assuming there should only be one file created after extracting the .tar file? I saved it in the default folder of Linux on the ChromeBook (Linux Files) and ran the two commends listed above:

chmod 775 SimpleHelp-Technician-linux64-offline
sh SimpleHelp-Technician-linux64-offline

I have over 30 years of DOS/Windows experience, but not much Linux experience, so it’s likely I’m missing something simple.

That is odd. Not really sure what’s wrong. Instead of using SH to execute it, try using period forward slash, ./SimpleHelp-Technician-linux64-offline and or using chmod 777. It shouldn’t matter though.
Also, make sure you are in the same directory as the file you are trying to execute. You can use the command ls for list directory

If you figure it out let me know. I am curious now.

1 Like

I’ll try it out now. I appreciate the help.

That worked!!! As soon as I entered that command it started installing and now works. Thank you so much for your help. I really do appreciate it.