Installing agent on ubuntu server 19.04

Dear all,
I’m trying to install the simplehelp agent on Ubuntu server without GUI. I downloaded both offline and online tar’s but no luck.
was anybody was successful in installing the agent.


Can you install this without a GUI? Doesn’t quite make sense to me, but we are only using Windows/Mac agents.

Hi, it’s not about installing simplehelp server on Ubuntu but we have a mixed environment windows/linux to administer and we want to have only “one tool”. For administering linux server with SSH under simplehelp :wink:

Hi Henri. You need to pass in silent installation parameters to get the service installed without a GUI. See Silent and Headless Installation here:

Generally, you can just untar the archive and then pass in:


The service will then get installed, configured and started.

Hi George,
Thanks for the answer but if I try to install it that way I will get a segmentation fault I Ubuntu?

I’d check that the binary is the correct architecture. Also, are you on the latest stable build?

I’m running

I was referring to the SimpleHelp server build (/version of your SimpleHelp server)

version 5.1

This is 5.1.0. I’d suggest either upgrading the server to a more stable release, or using the Remote Access service download from a more recent server (we have a test server up at if that helps where you can download a service binary from).

Hi Tried this also but no luck so this what I’ve done sofar:
Installed Ubuntu 19.04 and also sudo apt update && sudo apt upgrade -y so latest version
downloaded "Remote Access-linux64-online’.tar from

to local disk
To my Ubuntu server I transferred the file with FTP
mv to ~/simplehelp
un-tar with sudo tar -xvf
got file ‘Remote Access-linux64-online’
run it with ./‘Remote Access-linux64-online’ /S /NAME=“computername” /HOST=HTTPS://myservername:port

still I get Segmentation Fault (core dumped)


I just tested on a new server installation of 19.04. The following worked for me:


tar -xf Remote\ Access-linux64-online.tar

./Remote\ Access-linux64-online /S /NAME=AUTODETECT /HOST=

seems to go better but still nope I will include the screen output in a reply to you

That is all working correctly - it is complaining that there is no installed elevation utility in the log you sent. I’d suggest just running it with sudo to give it permissions to install.

Hi I “re-installed” openjava 11 jre and sdk and now it seems to work. thank you very much for your valuable support a pleasure to work with you :+1:
regards Henri