SimpleHelp Community

Installing SimpleHelp Server on Raspberry Pi 4B


#1

Hey all,
im trying to install SimpleHelp Server on my Raspberry Pi 4B running Linux 11 bullseye (aarch64). To make my life easier I used the SimpleHelp Install Script., unsuccessfull.

It downloads everything, but when it tries to start the server, it gives java error:

root@raspberrypi:/opt/SimpleHelp# ls
admin configuration DEPLOY images jre lib serverstart.sh serverstop.sh USAGE_TERMS.txt
root@raspberrypi:/opt/SimpleHelp# bash serverstart.sh
serverstart.sh: line 95: ./jre/bin/java: No such file or directory

It says that no ./jre/bin/java is found. But:

root@raspberrypi:/opt/SimpleHelp# cd jre/bin/
root@raspberrypi:/opt/SimpleHelp/jre/bin# ls
java jfr jjs keytool orbd pack200 policytool rmid rmiregistry servertool tnameserv unpack200

as u see, it also download java automatically and put it into the SimpleHelp Folder.
Am i missing something or where is the mistake?
Thanks
Furkan


#2

Hi

Have you tried this option to install SimpleHelp Server on your Raspberry https://simple-help.com/simplesetup#simplesetup


#3

oh wow, i never saw that tool i can use on my windows pc.
Well i gave it a shot and:

It did a few things, downloaded the files and extracted, but failed at the end. It also deleted everything it had extracted under /opt/SimpleHelp

Any ideas?


#4

Try this.

Download Raspberry Pi Imager https://www.raspberrypi.com/software/

Install and run Imager. Choose Raspberry Pi OS (64bit) setup options as required.

Choose your SD card and install

Once OS started get IP address of Raspberry Pi

Back to PC and run SimpleSetup install again

I just tested and it worked


#5

I found my issue.
I think my Raspberry is on 32bit, kinda.

Distributor ID: Raspbian
Description:    Raspbian GNU/Linux 11 (bullseye)
Release:        11
Codename:       bullseye

uname -m gives aarch64, but getconf LONG_BIT gives 32

Info related to this:

When i firstly tried the SimpleSetup, it downloaded the SimpleHelp-linux-arm64.tar.gz image. It failed like i mentioned. But then i grabbed the file on my own and extracted it, and i ran again into the Java error. That made me realize that maybe the Java Version which is included in the simplehelp installation package! So i checked firstly If my Raspi has any Java Version already:

furkan@raspberrypi:/opt $ java -version
openjdk version "11.0.20" 2023-07-18
OpenJDK Runtime Environment (build 11.0.20+8-post-Raspbian-1deb11u1)
OpenJDK Server VM (build 11.0.20+8-post-Raspbian-1deb11u1, mixed mode)

I found it under /usr/lib/jvm/java-11-openjdk-armhf. I just replaced the java folder in the simplehelp installation folder with my java 11 openjdk files and boom, it worked.

So since my Kernel is on 64bit, but my Raspi os is on 32bit, it creates some problems with SimpleHelps SimpleSetup: Since it automatically got the “SimpleHelp-linux-arm64.tar.gz” setup files, and the Java Version inside is only made for 64 bit os, it doesnt work with my Raspi OS. Would it be hard for the devs to make a better working logic here?

My simplehelp runs now with the workaround
Furkan