macOS Big Sur repeatedly asks for screen recording permissions

We’re experiencing an issue when attempting to connect to clients running macOS Big Sur. As with Catalina, Security & Privacy settings need to be allowed to allow for remote control and screen sharing.

However, on Big Sur machines the “Screen Recording” setting is not sticking. We’re prompted to enable, asked to quit and re-open Remote Support (as is expected) but upon entering the queue we’re asked to enable Screen Recording again (the previous settings is unchecked).

I’ve included a screen capture of this behavior. Is anyone else experiencing this issue/have a solution? We’re running 5.2.13.

I’ve had the same problem with MacOS Catalina - it eventually settles down, I can’t remember doing anything specific other than possibly deleting simplehelp off the client, reinstalling and maybe rebooting. It was a bit of a faff but it did work in the end.

I am also experiencing the exact issue. Using SimpleHelp 5.2.13. The only machine I have this issue with is a Mac running Mac OS Big Sur. I have over 150 other Macs running Catalina and Mojave without this issue. The screen recording security preference checkmark does not stick. This prevents remote users from controlling a Big Sur Mac unless someone locally enables screen recording again.

I am having the same issue, new out of the box iMac, Big Sur 11.1 setting will not stick, constantly prompts for permission.
Running Simple-Help 5.2.11

We are having this issue too, and it is a major problem for us. I have had to shelf 7 new M1 Mac’s and not happy about it.

I havnt tried these, as I dont deal with macs too often, but a couple community issues have been posted on something similar.

Hey everyone, 5.2.14 is here, and one of the line items…

  • [Bug] Fixed an issue where the Screen Recording permission was not detected correctly on Bug Sur 11.1.

… also, maybe helpful…

  • [Minor] New macOS guided permissions dialog allows a technician to request permissions from within a running session.

Did upgrading fix the issue or did everyone have to take different steps?

I have 10 macs that are having the exact same problem. They were all High Sierra and Simple Help worked fine but I upgraded them to Big Sur and I’m getting the repeat permission boxes. The version of Simple Help installed appears to be 5.2.2020 so I’m trying to figure out if I need to remove and reinstall it or if there’s another fix.

The settings stick in 3 of the permission fields but the Screen Recording seems to uncheck itself every single time.