Numlock on/off issue

I don’t know exactly when the problem started, but every time I connect to a laptop, their numlock is turned on or turned off depending on what it was before I connected.

This has been present for at least a few months I think.

Anyone else seeing this issue?

Happens to me every so often. Just click start>run and type OSK
This will open the On Screen Keyboard so you can turn it off

OK, I just realized (now that I’m not on my phone) that the On Screen Keyboard (OSK) only works for Caps Lock issues. Numlock isn’t an option on the OSK.

To toggle Numlock, create a toolbox that runs a powershell script with the following code:

$wsh = New-Object -ComObject WScript.Shell

The numlock issue has only been a problem in the last few months. One of the updates must have done something. I will log a support ticket with Simple Help because I also want them to address the Caps lock problem as well. Caps lock as you know does not work. I always have to use Shift to get caps on remote machines.

I could use scripts or run OSK etc, but it would make more sense for the development team to fix these two issues.

I wonder if the problem with the num lock is anything to do with my new keyboard which I bought in September. I can’t recall, but that time period sounds about the right time since this problem emerged. Not sure why changing my keyboard would affect the issue, but possible the two are connected.

I am closing this issue. I was googling the issue as I thought I really have to fix this, and discovered the technician guides talking about disabling num lock. Apparently there is a setting in sessions settings to disable numlock. Somehow this setting must have been enabled a few months back. I have a feeling I accidentally set this when I was changing the settings for something else!

So problem should hopefully be solved now!

1 Like