Online Installer for Mac

Is there a way to configure an installer so that a user on a mac can download it, double click it, enter their password and have it automatically connect without then having to go and also start the service? I thought this option was available at one point but I can’t seem to get this to work anymore.

I justed tested on my side and all worked normal. Did you test it on more than one mac? It can be something blocking the service. Some users now have antivirus on a mac machine… that sometimes can prevent the service even to complete installation. Please double check these steps and let me know.
Good luck!


I just disabled Symantec Endpoint and re-tested. I pick the option for silent install and uncheck Install Menu shortcuts. I see the following in the process list but it never starts up and then this process dies.

0 25373 25369   0 11:26AM ??         0:04.84 /private/var/folders/yh/bwkgztcn5hdgj5cc79syk0340000gn/T/AppTranslocation/59B3F69C-85CE-48D3-A455-610E35C72805/d/Remote -psn_0_1339719 JWPREPARE_FOR_LAUNCH_ONLY
0 25432 25373   0 11:26AM ??         0:00.61 /Library/Application Support/JWrapper-Remote Access/JWrapperTemp-1559751976-5-app/Contents/Home/bin/unpack200 /Library/Application Support/JWrapper-Remote Access/JWrapperTemp-1559751976-5-app/Contents/Home/lib/rt.jar.p2 /Library/Application Support/JWrapper-Remote Access/JWrapperTemp-1559751976-5-app/Contents/Home/lib/rt.jar

Please check if the endpoint has any block in effect for it. Even disabled it can be blocked.
Please check the following for all the steps:

I just tried from another Mac (this time there is no Symantec Endpoint client on it) and same result. Something is definitely not right with the mac installer in silent mode. If I sudo and then run osxwrapper manually from root it works ok but not double clicking it…

Hi Joao -

So, support confirmed with me the behavior I am seeing is accurate. I am not sure if you are testing something different or if you have some defaulted elevated privileges on your mac but a silent install on the mac does not seem to work without launching it without some sort of elevated privileges.

I would like people to be able to just download the online agent, double click on it and move on… Instead it seems cumbersome… Much easier for Windows users…

Ok, Now I understand. Please check this link:

It shows that for Mac or Linux: If you are deploying on Linux or macOS the credentials you supply should be root or a user capable of sudoing with their usual password.

I hope this helps!

But when I download and launch the installer that is configured to deploy silently it does prompt me for credentials, I enter them and it still does not start up. This doesn’t make sense.

Then it seems the user account doesn’t have administrator rights. Most of the windows users accounts are enalbled with administrator rights and that makes windows more vulnerable to attacks. Linux and mac require a password to be entered for extra security against unauthorized system changes.
If the user account is standard then it will not start the service. If you run it locally using terminal and with administrator rights it works fine. I’ll try to simulate your situation here and so how we can go around it, if possible. Wish me luck!