Raspberry Pi 4 installation help. Java not working

I am having issues running simplehelp on a headless buster install.
Here is the output.

It seems like buster doesn’t support oracles java.

pi@pi4simple:~ $ java -version
openjdk version “11.0.3” 2019-04-16
OpenJDK Runtime Environment (build 11.0.3+7-post-Raspbian-5)
OpenJDK Server VM (build 11.0.3+7-post-Raspbian-5, mixed mode)
pi@pi4simple:~ $ sudo sh /opt/SimpleHelp/serverstart.sh
OpenJDK Server VM warning: Option UseMembar was deprecated in version 10.0 and will likely be removed in a future release.
pi@pi4simple:~ $ java.lang.ClassFormatError: Incompatible magic value 529205248 in class file SecureRunner2
at java.base/java.lang.ClassLoader.defineClass1(Native Method)
at java.base/java.lang.ClassLoader.defineClass(ClassLoader.java:1016)
at java.base/java.security.SecureClassLoader.defineClass(SecureClassLoader.java:174)
at java.base/jdk.internal.loader.BuiltinClassLoader.defineClass(BuiltinClassLoader.java:802)
at java.base/jdk.internal.loader.BuiltinClassLoader.findClassOnClassPathOrNull(BuiltinClassLoader.java:700)
at java.base/jdk.internal.loader.BuiltinClassLoader.loadClassOrNull(BuiltinClassLoader.java:623)
at java.base/jdk.internal.loader.BuiltinClassLoader.loadClass(BuiltinClassLoader.java:581)
at java.base/jdk.internal.loader.ClassLoaders$AppClassLoader.loadClass(ClassLoaders.java:178)
at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:521)
at SecureRunner1.(SecureRunner1.java:402)
at SecureRunner1.(SecureRunner1.java:227)
at SecureRunner1.main(SecureRunner1.java:52)

I was able to get the server to work on a pi thanks to support and this link.


Hi Mark,

I would try installing a java 8 JRE and running with that. I’m not sure if you can get that via APT but you could also just download it from the web, the following page has Java 8 built for a variety of platforms I think:



I have tried following these steps with the latest version of java8 JRE on that site, but I still cannot get Simple-Help to work on the Raspberry Pi.
When I try to start the server using version 8 I get: Unrecognized VM option ‘UseMembar’ Error: Could not Create the Java Virtual Machine. When I try starting the server with version 11 JRE, I get the java crash you posted above.

Any help would be greatly appreciated! Thanks!

I’d be careful about putting Java (from Oracle) on your machines, their licenses have changed and it is no longer allowed to be used in any type of commercial way. Everyone has switched to openjdk. That being said though I really don’t think you need to install Java at all to get Simple-Help up and running. They package everything you need in together. (The install procedures do not mention anything about java https://simple-help.com/install---linux )

Also Simple-Help now has something called “SimpleSetup” that lists RaspberryPi as a install target: https://simple-help.com/simplesetup … not sure if you’ve tried that.