SimpleHelp Community

Sessions not being terminated


#1

Is anyone else having an issue with simple help session you have created and closet out cleanly remaining open under the “Active Sessions” section of the access tab from within the Technician Console?

Thanks,
Dennis


#2

What version are you on?
That happened years ago. Was fixed. Make sure to submit a ticket to support.


#3

Yes, we are seeing it. Not every session, but maybe 1 in 5.
On version 5.2.5

We need to go to active sessions and terminate the ghost session from there.


#4

Saw it the day before yesterday. I closed a session, tried to connect to another computer, got the license error the other session was still active and I looked like an idiot telling the customer to run the program again. Also great fun not gaining elevated permissions on reconnect.


#5

We are seeing this as well. We are on 5.2.7. Thanks!


#6

We have seen sessions not be terminated when closed from tab.

And yes, I have put in a ticket for this…


#7

same issue here. Need to manually terminate connections.
V5.2.3


#8

Never posted my version 5.2.7


#9

Yes same here since v5.2 - I only have one license so tend to spot it very quickly. The other lingering annoyance is that “Joining” stays on screen way after the connection has actually been made. You can interact with the remote behind the “Joining now” message. SH have asked for logs I think…


#10

+1
Version 5.2.7 running on Server 2016

Fresh install of software onto new server. Imported from 5.2.5 on a different server.


#11

I am running Simple Help Version 5.2.7 and I have noticed the problem occurring quite a bit in the last few releases. I don’t think it started with 5.2.7 but is noticeably worse in the latest version. Hopefully it will get fixed soon.


#12

I am curious what is different with your setups from mine, if anything.
I have not had this issue and there seems to be quite a few that have. I am not complaining :stuck_out_tongue: Just curious.Maybe if you all share your config, but remove the sensitive bits like your ip etc Maybe then you can find a commonality between you all.

Just out of curiosity. Have you tried clearing out your technicians cache?


#13

It is difficult to say as there seems to be no rhyme or reason to it. Today for example, I had a lot of trouble staying connected to a machine that I had no problems connecting to previously. The only thing that helped was changing the connection from https to udp, though why that would make a difference I don’t know as I had no problems with that machine before. But it might be the client. I had a similar problem with another computer at the same client - so maybe it’s their broadband?

Today, no issues with sessions not being terminated. Having said that, this client has all their machines setup with https whereas other clients have it setup with udp. This might account for the difference?


#14

Check out the Update just released. It may fix the problem.

Check it out:
[Bug] Fixed an issue where sessions are not disconnecting cleanly, and are only being removed once they time out.

  • [Bug] Fixed an issue causing a pause when Direct TCP sessions are connected.

Maybe between those 2 bugs being fixed your issues might go away??


#15

Pleased to hear this. I have updated immediately. It sounds like it might fix my issues! I see there is now a remote working option below my online, offline list of computers. Will have to see what that is about when I have time.


#16

I’ve just upgraded to 5.2.9 as a matter of course but also because I’ve been having trouble with the session disconnect problem. I was trying to upgrade four laptops remotely and because I’ve only got one license, I keep terminating and reconnecting. Had to give up as just do one at once because of connection issues. Will see if 5.2.9 is any better as am doing another four tonight.


#17

5.2.9 is a no go for us.

LDAP Authentication appears to be broken after our upgrade. Is anyone else using the advanced ldap… UserPrincipalName=${UserName} or sAMAccountName=${UserName}?


#18

Sorry. No. Only using simple AD LDAP.


#19

We are using it, but still on 5.2.7. Let me know what you find out. Thanks!


#20

Session connectivity seems okay/maybe better in v5.2.9 but Windows key pass-through has broken on my setup :frowning: