Sticky Windows Key


Running SimpleHelp 5.1.6, I sometimes have a “sticky windows key” in my remote clients, which means when typing text, it’s like doing Win+key shortcuts (ie ‘e’ opens explorer).
I have to hit the windows key again in the client for it to become “non sticky”.

This happens randomly. I have a session log of a session where this happened if it may help.

Anyone running into such keyboard glitches ?

Best regards.

Yes, from time to time. The solution is always to close the Remote Access session and reconnect.

I also have issues with various keys sent.
For instance, I have a French Win10 1903, I take a remote session to a French Win10 1903, in which I open putty / a html console or whatever other app, and most chars like ‘@’, ‘[’ and ‘]’ don’t work anymore, being sent as ‘^@’ or so.

Basically, all characters that are typed by using ALT-GR + key don’t work well (they work in windows notepad, but not in most apps like putty and so on).

@SimpleHelp team: The keyboard usage (especially the French one that uses alot of ALTGR + key combinations) is terrible since the beginning. Is there anything that can be done ?

Best regards.

Me too - always had problems with some of the more unusual keys sequences. For example, Alt-Enter doesn’t work in an Excel cell remotely - this is the key sequence needed in Excel to enter a CR into a cell. Full-stop sometimes causes problems esp. from numeric keypad. And finally, SimpleHelp sometimes grabs key presses even when the remote window is not in focus.

But all in all, minor problems - except that Alt-Enter in Excel. That’s a pain when I need to help a client with their invoicing spreadsheet where they use it a lot in the address field.

@Rob_Nicholson Thanks for the report

@SimpleHelp @gchristelis @Antony :
Please consider looking at those issues.
Using SimpleHelp with a french keyboard is very unpleasant.
Use a Windows 10 1903 x64 french machine as technician, access a Windows 10 1903 x64 french machine via remote accessn, open putty to a linux machine (or whatever), try to use special characters like \ @ € ’ | .

Most of the characters done by special key combinations don’t work correctly on putty, mobaxterm, or putty next gen.
In this example I use putty since that’s what I reproduce the easiest way, but there are other applications (customer windows apps) that do show a similar behavior.
Of course I tried mapping locally and / or mapping remotely.

Best regards.

Tried with SimpleHelp 5.2 beta 1 today.
Same results !
Regardless of using “map local pressed keys to remote” or “map local text typed to remote”, there’s no way to get a ‘@’ in a putty / mobaxterm program opened on remote computer.

Btw, even when typing to standard notepad.exe, “Send keystroke(s)…” function does not work at all for me. Tried ALT+F just to open the file menu… Doesn’t work. Needless to say that ALT-GR+0 didn’t work either.

Can I at least get a response from the SimpleHelp team ?
Is the bug reproductible ?


Just so you know, this still happens on SH 5.2 beta3.
Even the simple character ‘ù’ doesn’t work.

Also, I’d like to thank the developpers for their replies… Really helpful here.
I can send you a french keyboard if you like… Honestly, I’d do if you would take a couple of minutes to make a reply, just to acknoledge the bug, even without any fix.

Tried on SimpleHelp 5.2 beta 5 today…

Really no reply ?
I’ve got two different SH servers, both have the same behavior (5.1.6 and 5.2-beta5 versions).
No litteral way to use a non english keyboard to type special characters (ù and @) without changing settings on simplehelp console.

I think there must be a couple of people having that problem.

@SimpleHelp @Antony @gchristelis
Another time to the dev team: please help me, acknoledge the bug (happy to send you logs or whatever you need to help identify it).
My whole sysadmin team is totally fedup with using simplehelp because of that stupid keyboard bug !

Best regards.

The SimpleHelp community site is not designed or intended to be a forum for users to discuss specific issues with us, but rather a place for the community to interact. We have separate triage and bug tracking systems that we choose to not make public. If you wish for specific confirmation of an issue then we will be happy to respond to you directly.

As it turns out, the problem is far more complicated than you intimate. There is definitely a limitation of the way that keyboard mappings are inferred on Linux. We currently use xmodmap which is accurate with a single locale but not usable with multiple locales. As I’m sure you are aware, XKB creates layout groups on a per-locale basis, so it is not possible to represent this information as a table the way xmodmap does. xmodmap isn’t usable in this situation.

Again, contrary to what has been suggested, we have been looking into extending support for multiple keyboard layouts. You can use xkbcomp to get the layouts (with group) as a .xkb resource, but SimpleHelp needs to parse this. This is what we are working on at the moment: a XKB parser to suppose multi-locale key sequence reproduction on Linux. We are, however, also working on many other features, improvements and enhancements and continually balance our efforts as best we can.

Also, it should be emphasised, that this is specifically an issue when keycodes between the client and remote machine do not match. SimpleHelp then attempts to reproduce characters by querying the remote machine for the key sequence to create. If keycodes match, then switching keyboard mode works just fine.

Thanks for your answer @gchristelis

I’m sorry to make this public, but I have had multiple non answered support queries, perhaps never received by your team.
Meanwhile I’m getting nuts having the same complaints from my sysadmins every weeks.

I can understand that it is a complex problem which doesn’t have a simple “make_it_work=True” solution, and I never suggested it was.
I really like SimpleHelp in the first place, but this makes the product diffcult to use for our non US/EN keyboard users.

Now if I understand well, as a current workaround, since the problem is Linux kb mapping related, if I happen to reinstall a Simplehelp server on Windows, I should not encounter any of those issues ?

Best regards.

1 Like

Anyone reported this one recently? It seems to be a bit worse with the latest version. I’ve just had to close SimpleHelp as I was unable to press Windows-R (run) or Windows-D (desktop). In fact, it’s doing it right now as I have the console and a session open. It’s rather frustrating as it’s been there for years.