SimpleHelp Community

Testing Remote Work - credentials correct but not working


#1

In my first test of Remote Work a box popped up pre-populated with domain credentials in the user slot. We put in that user’s domain password but it comes back and says credentials not valid. Are we missing a step?

5.2.9 build from yesterday (4/29/2020)

Thanks


#2

Did you use domain\creds format?


#3

Yes - domain\creds format was used - that is already answering my question a bit. Something isn’t working right if we are prompted for those and use the correct password but don’t get in.


#4

I’m experiencing similar, after having just upgraded from 5.2.7 to 5.2.9 and playing with Remote Work.

I’ve submitted a support ticket with testing and log excerpts.


#5

Same issue here. Lucky enough we just testing and have yet to offer it to any customers. At login screen no credentials work (either domain or local)


#6

Also… Does everyone else come up with a default username “simplehelpadmin” already entered?


#7

I can confirm I am also experiencing the same issue. I upgraded from 5.2.7 to 5.2.9 and have been trying to test Remote Work, however, all attempts end with credentials invalid errors.


#8

We’ve found that we can login once per case sensitive user name using LDAP. After first authentication that case combination cannot be used again.


#9

Mine did. And for me its credentials worked (assuming technicians are allowed to connect from anywhere, based on IP restrictions).


#10

This is the content of my support ticket, submitted ~41 hours ago, no response to date. You may be able to check your logs to confirm we’re experiencing the same issue (it looks like we are):

Hi,

Today I upgraded SimpleHelp from 5.2.7 to 5.2.9, as well as pushed updates to all monitored systems.  I'm testing Remote Work however am not able to get it to work.  I've linked our account via Administration > Licenses and see the Remote Work 10000 entry.

Administration > Remote Work > Allow Operating System Authentication wasn't ticked - now ticked.  If it's not ticked, the client returns "Incorrect Password", but the server has logged:

20/05 15:52:03.948: M593-19 05:52:03.948 (+    1) [Authentication] Valid tech connection attempt MYDOMAIN\myusername, checking password...
20/05 15:52:03.948: M593-19 05:52:03.948 (+    0) [ProxyServer] Incoming IP identified as x.y.38.214
20/05 15:52:03.948: M593-19 05:52:03.948 (+    0) [ProxyServer] Remote work token received (linked machine is SG_2487609386730750724)
20/05 15:52:03.948: M593-19 05:52:03.948 (+    0) [ProxyServer] No session token passed in.
20/05 15:52:03.949: M593-19 05:52:03.948 (+    0) [ProxyServer] Login INCORRECT, disconnecting tech now
20/05 15:52:03.949: M593-19 05:52:03.948 (+    0) [LoggingFramework] Logging event FailedTechLoginEvent (Technician Failed Login)
20/05 15:52:04.248: M593-19 05:52:04.248 (+  300) [ProxyServer] Disconnecting with reason: ''


Each time "Allow Operating System Authentication" option is toggled, a new Remote Work group is created in Administration > Groups.  Its option "Group used for Remote Work logins" is also not ticked by default, which I assume should be?

After setting up my PC to test Remote Work functionality, I still can't connect.  The client receives error "Incorrect Password", but the server has logged:

20/05 15:54:13.672: M593-19 05:54:13.672 (+    0) [Authentication] Valid tech connection attempt MYDOMAIN\myusername, checking password...
20/05 15:54:13.672: M593-19 05:54:13.672 (+    0) [ProxyServer] Incoming IP identified as x.y.38.214
20/05 15:54:13.672: M593-19 05:54:13.672 (+    0) [ProxyServer] Remote work token received (linked machine is SG_2487609386730750724)
20/05 15:54:13.672: M593-19 05:54:13.672 (+    0) [ProxyServer] No session token passed in.
20/05 15:54:13.673: M593-19 05:54:13.673 (+    1) [ProxyServer] No specific filter for SG_2487609386730750724 included. Using default.
20/05 15:54:13.673: M593-19 05:54:13.673 (+    0) [ProxyServer] Attempting Remote Work OS login
20/05 15:54:13.690: M593-19 05:54:13.690 (+   17) [ProxyServer] OS authentication granted for MYDOMAIN\myusername
20/05 15:54:13.690: M593-19 05:54:13.690 (+    0) [ProxyServer] OS authentication succeeded but there is no Technician Group configured for Remote Work.
20/05 15:54:13.690: M593-19 05:54:13.690 (+    0) [ProxyServer] Login INCORRECT, disconnecting tech now
20/05 15:54:13.690: M593-19 05:54:13.690 (+    0) [LoggingFramework] Logging event FailedTechLoginEvent (Technician Failed Login)
20/05 15:54:13.990: M593-19 05:54:13.990 (+  300) [ProxyServer] Disconnecting with reason: ''

Additionally, in Administration > Remote Work the Set Group button shows no results, even if there's Groups configured for Remote Work (I created an empty one as a test).

Regards,
Steven.

Seeing others may have also encountered this they may be already looking into it.


#11

Version 5.2.10 has fixed it for me. Once upgraded, I double-toggled the “Allow Operating System Authentication” option (on->off, off->on) and removed the original (higher in list) Remote Work group. Not sure if it’s required, but it didn’t hurt.