Tunnels - Launching local application on Mac

So, we love the Tunnel feature. We’ve used this in many products before, but this implementation is absolutely awesome from a performance perspective.

My only problem is, I can’t get any automatic application launching. Has anyone gotten this to work for any application on a Mac (Technicians are Mac)? We regularly use ssh as well as web sessions. I’ve tried the equivalent terminal/command like:

/usr/bin/ssh user@localhost -p ${PORT}

But, nada.

For webpages, I’ve tried things like:

thinking that might fire off the default browser. Again, nada.

Anyone have this working? It’s awesome now, but would be so much nicer to be able to fire off the browser or ssh or whatever automagically.


Hi Trey,

Yes, we use it all the time. Just place open before the command like "open${PORT}. You might look into using Royal TSX. It’s an amazing application we use for all our RDP, SSH, Web, etc. type connections. We tunnel them all through Simple-Help! Hope this helps.

Thank you for sharing - this has never worked for me but following what you did, it does!

Yes, Ted, thank you! This did help for the browser! Looks like we won’t be able to get RDP to work with the native Microsoft client. I’ll check out Royal TSX. Thanks!

For those who stumble on this post there is a good post here by realmx2: How do you use tunnels?

also to open the default browser on a windows machine use: explorer “http://localhost:${PORT}”

for windows to use rdp use: %windir%\system32\mstsc.exe /v:localhost:${PORT}

1 Like