SimpleHelp Community

Unable to connect after upgrading to v5.4.3


#1

I’ve just upgraded to v5.4.3 and now I’m having trouble connecting to devices. Just sits at this prompt forever. If you close the window and try again several times, you finally get to the “The remote computer is updating”. Just hoping that I can get back on. Assume I can downgrade? It’s all backed up. My connection is via http on port 8008. Anyone else had difficulty?

image


#2

Once you get to the “Updating” prompt, it sticks there as well. Been watching this one for 10 minutes so far. My laptop hasn’t been upgraded yet so will image that and try some diagnostics.


#3

Yes, big BUG I’m afraid. It’s trying to connect using HTTPS which we’re not using. This is what happens on a client after upgrade. And the “More details” report.

image


#4

If your access clients are updating, you cannot connect. That’s normal. The client updates went a bit slower with this update than older ones, but I wouldn’t downgrade yet. There is an issue with MACs where their client wont update automatically.


#5

I left it updating for an hour :slight_smile: However, “Auto restart” worked immediately. My initial panic does seem to have been a little knee jerky! It looks like all the devices are eventually coming on-line. But that HTTPS error message is real. That particular laptop is turned off now so can’t check.


#6

Something else to look at is the network settings. Just make sure that they are all still correct.

Glad to hear your machines are mostly online. :slight_smile:


#7

I’ve spoken to support and the problem with not been able to connect to an older version (and effectively force an “Auto restart”) is now noted as a fault and will be fixed.

In previous versions, when you connected to a client with an update to the SimpleHelp client, it would upgrade automatically and then connect. This doesn’t work in v5.4.3. You have to manually do “Auto Restart” first and then you’ll be able to connect.


#8

Is there any QA done to this versions before releasing a new build? Every release is got more bugs than previous, is slower and I go thru a lot of stress with every upgrade. And all this without getting significant features or improvements. So frustrating, I’m afraid to upgrade.


#9

I’m not aware of a beta program but I hear what you’re saying :frowning:


#10

I have similar concerns so I wait 30 days before deploying any updates. I’m still on 5.3.9 due to the stability of it. Very nervous about 5.4. The 30 day delay is the hope that any bugs are raised and SH releases an update within that time period. Any update, results in another 30 day wait.


#11

Hello…Just to share my experiences here with the 5.4 upgrade. When 5.4.1 was released I went from 5.3.9 to 5.4.1 on our Linux host and the issue I noticed was the fact that the client did not upgrade automatically when I clicked on the client for remote access. It has always done this in the past. So I back-revved to 5.3.9. I opened a ticket and they said to try the autostart functionality which I have never done before. So when 5.4.2 was released I gave it another shot and selected autostart on a few systems and it worked perfectly. So I did the same on the several hundred systems on mass and everything worked flawlessly. As a side note the SH persistent remote access client upgrade was triggered as “informational” on one larger customer running crowdstrike falcon but that is expected since this is a java application so it makes sense. On 5.4.3 we had some issues with the caps lock not working properly on some systems. More of an annoyance. But they fixed that on 5.4.4 which was released a couple of days ago.

So really the only big issue we had was the clients, not auto-updating (thus forcing the auto-restart) when we connected to them. It is a minor issue now since we just do auto-restart on-mass and all is well.

So I will say 5.4.4 seems much faster on disconnects, etc.

Just FYI…YMMV


#12

Hello all,

I’ve been using SH for a few years now, it’s our support mechanism for industrial PCs integrated into our products deployed to the field. I haven’t generally had issues with upgrades in the past, and they have mostly been pretty transparent. This bug did bite me though, and I see some people are having luck with “Auto Restart” I’m not familiar with how to do this, and at this time 60-70% of our deployed PCs won’t connect. Where is the option/button/procedure to initiate the autorestart? On the client side, or in the technician console?

Thanks for any tips!


#13

Basically in the tech console under access tab you will see all your devices. Just click one of them and go to the advanced options and controls icon (sprocket) and select “Auto Restart” button. This will force the client to update and automatically start the client. It will appear to go dark for a few seconds but then come back up and you should be able to connect. It did this on mass with all of our remote clients when we confirmed it worked fine.

HTH


#14

Thanks Mike!
I had never explored those options, thanks for pointing me in the right direction. Hoping to have this all resolved in a few minutes.

Pete


#15

OK, so it’s out of the frying pan and into the fire with this unfortunately. I can see that the auto restart option seems to have worked for all of our online clients, with the UI in the technician application showing that the clients are up to date, but when I connect to many of these hosts now I get a grey screen, and if I wait a few seconds I get this Connection Failed message -

Is there something more I need to do after the client is updated to get remote interactive sessions to work? The majority of the client PCs are Windows XP, if that is material to the issue.


#16

I had the grey screen after updating and my heart sank. But it reconnected the second time…


#17

Yes I did the same - only tip; it can only be run when the client is online. So you have to keep doing it if you have clients that aren’t online 24/7.