Upgrade Digital Ocean droplet but technician stays the same

I upgraded my Digital Ocean droplet to latest software (or thought I did?) but when I run my technician console on my windows 10 pc, it still shows older software version, even after a reinstall?

Have you tried deleting the Jwrapper folder under Programdata and then reinstalling,

Welcome to the SimpleHelp community Neil.

Can you let us know how you upgraded the server installation? I’d suggest making sure that SimpleHelp was restarted after you performed the upgrade.

You can easily check the server version by accessing the /allversions page of you SimpleHelp server installation too.

Can you advise the correct way to upgrade SimpleHelp on a Digital Ocean droplet. Need to upgrade to 5.2.1 and it will be the first time we have done this, so any info would be appreciated.

@Vic_Murray - In the future you start a new topic for this, and not post under a 2 month old topic. The answer you are looking for is on this page, near the bottom there is an upgrade script…

1 Like

Or you can do this
Used Filezilla to upload SimpleHelp-linux-amd64.tar.gz to /opt folder

from Droplet console
cd /opt

tar -zxvf SimpleHelp-linux-amd64.tar.gz

cd SimpleHelp

sh serverstart.sh


Lastly Filezilla onto /opt folder again and delete SimpleHelp-linux-amd64.tar.gz

All updated and working

Now someone can close the post to keep realmx2 happy

@Vic_Murray - Sorry maybe my tone came across wrong, but wasn’t complaining. Just letting you know that etiquette would be to start a new topic, not to post a new question on someone else’s topic. It came from a trying to inform place and not a correcting place.

I’m glad that you were able to solve your problem. For others though I would like to add on that they should backup the SimpleHelp folder first before updating right over it. I would highly advise people to use the script that simple-help provides as it automates the download, backup, extraction, and then restarting of the server afterwards.

Also as another note I wouldn’t use or suggest filezilla as they have been found to bundle malware/adware in their installers multiple times. WinSCP is opensource and works great for all your file transfer needs.


Hi Neil Dont know if you got this figured out.

Now and then simplehelp technician gets stuck and needs to be removed.
Close Simplehelp technician.
Delete this folder:
C:\Users\YOURUSERHERE\AppData\Roaming\JWrapper-SimpleHelp Technician
Then re-download your simplehelp technican and run it. You should be good.