SimpleHelp Community

Keep being prompted to change the SimpleHelpAdmin password


#1

We are testing SimpleHelp (trial license) to see if this will be the perfect fit for our company. I am pretty sure this will handle everything we need and more. I am the IT Director for my company and have been in the industry for almost 30 years now. So, I am fairly competent I can set this server up and get it running. Until I actually tried. :slight_smile: The issue I am currently experiencing is laid out below.

I installed the server on an Ubuntu server. I am able to get to the website and download the technicians console. (However this is only working in safari, no chrome based browsers are working yet.) Anyway, I installed the technicians console, open it up and am prompted to reset the SimpleHelpAdmin password. So I change the password, go through each option under the administration console and make all the changes needed. Then once that is done, I made a backup of my configuration. I closed the technicians console and then reopen it, hoping to log in with a regular technicians user account to test it. But it keeps opening as the SimpleHelpAdmin and it keeps prompting me to change the password. I also tried getting one of our IT support techs to download the technicians console and when he opened it up it immediately prompts him to change the main SimpleHelpAdmin password.

What am I missing here? I have configured the server (except for email, that will be a job for next week) and was able to add one test PC to the remote access tab. But if I close the console and reopen, it prompts for the admin password to be changed.

Please Help!
David


#2

Hi David, a few questions…

  • have you engaged support about this?
  • what version of ubuntu
  • what version of simple-help
  • have you tried blowing the install away (delete folder) and then redownloading and starting fresh (since it’s a brand new install)

#3

Sorry, I missed the email notifying me someone replied. The requested info is below, followed by a bit more information.

“have you engaged support about this”
I have not spoken with support as I am currently testing the software using the demo trial license. I’ll be buying the product as soon as the trial ends.

“what version of ubuntu”
Ubuntu 22.04.3 LTS

“what version of simple-help”
v5.4.10

“have you tried blowing the install away (delete folder) and then redownloading and starting fresh”
I did this twice and on the third try it kept the Admin credentials when I set the password on the first try.

Follow up information: After finally getting the software to keep the admin password, I still notice that chrome doesn’t work correctly when I try to access the website. Also, in both chrome and safari, if I click on the “Install” button for anything other than the “Technician Console” I get sent to a page that only has the simple help logo either in the middle of the page or at the top of the page. There is no way to get a link to download the “On Demand Sessions” software or any other software. I find that extremely odd, but since we are using the software for PC’s located within the company I just grabbed a copy of the “Remote Access” software and had my guys install it on all of the computers in the office. I would like to get the “On Demand” part working for the 4 or 5 users we have that work remotely and NEVER come in to the office, mainly because they live on the other side of the country from HQ. I guess I’ll try changing the HTML in order to see if I can get it to work.

But now this is the issue I’m mainly concerned with getting fixed. Although this may be more of a feature request.

We use Office 365 and I read an article that explains how to make it work by adding an azure application etc. I find that an extremely cumbersome work around. If the SH devs could add in the options to allow the server to use STARTTLS then I could setup the email system without have to add anything into our Azure system. Maybe I’m just being petty but to add it into our Azure system then the server MUST be accessible to the outside world (internet access) and I would rather keep this server only accessible from within the organizations network. If I could use STARTTLS then this would be possible as I’ve done it with other products in house. If this will never be allowed, then my only other option would be to move the server over to an AWS server or some other web hosting company. Anyone have any advice for this type of situation? I’m not 100% against opening up the firewall for this software to work, but if it can be avoided then I would love to keep all ports closed on the firewall.

Let me know if none of this makes sense and I’m just rambling or if I need to provide more information.
Thanks for the help!


#4

Hello…Really odd you are having all these issues…Especially the browser issues…Could this be something internal within your enterprise? Perhaps some sort of firewall inspection? Perhaps it is having some sort of issue with the letsencrypt certificate?

As for the STARTTLS I am using that now under Email Configuration for SSL/TLS and manually selecting port 587 to relay off another linux box. It has always worked perfectly. Could you explain more in detail what is not working with STARTTLS? Are you trying to do this with O365?